Teie kommentaarid

Could you check autostart setting? Maybe bluetooth device changed? Permissions?
We didn't change autostart feature - it's still based on same broadcast receiver method. 

Maybe you get update to your phone?

Please remember that new Android introduced some new permission change model. You need to add different location permission if you want to use autostart.

Please, check also this: https://dontkillmyapp.com/

It's possible that after phone update some permission settings or settings related with battery management changed.

After pushing 7.7.7 I got zero reports about it. Also we rewritten that stuff and the only way it is still shwoing like that is to having on some device older verison. Check if you have other devices.

Right now folders are create only when connecting to Drive. So it's not possible to create duplicate when using the app after approving the app.


Do one thing. Make sure you are using 7.7.7, clear all dir, log out from Drive, then sign in again - do full backup (manually) and see if dir are created once again. It should be working. 

Also remember. If any other app got access to these folders, doing something - they are revoking access from Fuelio. We can read only files saved by the app. We don't have access to your Drive.

Update on this thread. Google Drive API stuff was rewritten in Fuelio 7.7.7 beta 17 (if you are in beta channel update will be here later today). 

Issues should be resolved. I'm using different way to check if directory structure is created. Less requests to Drive API etc.


This will be of course part of stable 7.7.7 release.

Hanna, you're the best! 
Now we've finally found something. I was able to reproduce it! 

Now I need some time for debug, but finally, I'm really happy about it. 

Thanks! Checking this. Didn't try clearing cache and data, but this should be the same as uninstall/install

Maybe I'll see something using this way. Thank you very much, I need to catch this. I don't think this bug is massive, I just need to find out what's the trigger here.

Coud you give me full path - how to reproduce it?

We are unable to do it. We are trying for a long time.


Not sure if this is random Google Drive API bug or we miss something.

If you remember -did you uninstall app and install again, which option you are using when this is happening? Sync? I mean full backup, manual backup.

Coud you give me full path - how to reproduce it?

We are unable to do it. We are trying for a long time.


Not sure if this is random Google Drive API bug or we miss something.

If you remember -did you uninstall app and install again, which option you are using when this is happening? Sync? I mean full backup, manual backup. 

Please, restart phone before it to make sure gps module will re-init. 

We are saving values to text file, then we analyze it. It looks like somewhere were wrong with speed values - but it's taken from gps module so we can't do anything here. 
Everything else looks fine. If other values would be wrong - we can talk about some bug but it looks like your phone gave all the data except speed. 

But we'll see. I'll check it tomorrow also with conected to usb.

Please, record next trip and see.

Check also if you have free space on your device.

To generate speed chart we need files that are parsed. If there's a problem with space - it could be the issue.

What's also possible - just phone gps issues. Restart your phone to make sure it will boot again.


Hi. Interesting. I got Pixel 4XL and I'm using phone with Android Auto. Just checking my last trips. 

I'll check it tomorrow once again.