En revisión

Error importing database (file not found)

Pepote Garcia hace 6 años actualizado por Prima Knh hace 2 años 7

I formatted my phone today and made a backup to sd card (database, not CSV). After format I copied Fuelio folder to my SD card and app can't import: says file not found. Path is /sdcard/Fuelio/backup-db/fuelio6.db and version is 3.80.

I'm doing anything wrong? Can I convert this file to a CSV format?

Hi again

I found a solution: used Root Explorer (it's the app name, phone not rooted) to find Fuelio exports and found in /sdcard/Fuelio but when connecting to my Mac I don't see this folder. "Real" path is /storage/emulated. Phone is a Nexus 5 with Android 5.0.

Anyway, renaming file to fuelio7.db, importing it and reopening the app worked for me. 

I hope this details help you to find and fix the problem...

En revisión
Yes. You had file in wrong directory. But changing name to fuelio7 will break future updates. Send me your CSV and I'll convert it to fuelio7.db (it's different schema). 

fuelio6.db is old database schema. There is new one in the lastest version. That's why CSV backups are more reliable. 

Fuelio is updating database structure while updating app and where there is a new schema. 
I don't have a CSV, only have he fuelio6.db backup... I need to convert fuelio6.db to CSV to import it...

Anyway, I don't understand this "relialability". If making backups of databases are insecure, don't allow users to make this. We trust on this backups, so has now sense allow to make a dump that can't be restored (even with paid version).
They are quite safe. And the database schema is updating automatically. Probably you have old backup and you didn't update Fuelio from Play Store. If you will export database right now you'll see that the file will have name fuelio7.db. 

It's easy to convert old database schema to the new one. But renaming file is a bad idea. Send me your file - I can update it to the lastest version or like you said. At the moment you have old schema and for example you can't use foreign currency feature.

I always updated Fuelio from Google Play Store (where can I find the standalone???). My phone is a stock one, without rooting nor strange things, and I paid for pro version months ago... 

I know what I did: I opened Fuelio (3.8.0), went to export database to SD and made a backup to my Mac via USB. And there's two options: the backup didn't work and the fuelio6.db existed becase of a previous one, or the backup didn't work dumping an old database version. As you can expect, I didn't care how Fuelio works internaly, I only know that I made a backup and didn't worked...

I restored renaming to fuelio7.db, imported, exported to CSV, cleaning app data and importing CSV again...
It's not possible to export old shchema with Fuelio 3.6.0+ (2014-05-09). Database schema changes when foreign currency feature was added. Please go to Settings, try to turn on foreign currency and go to see if you can define them. If you see crash. Schema is old.

I'm saving .db backups with database version to make sure users won't import other files. 

Here mentioning about error importing database its a very useful information to me. Fuelio folder to my SD card and the app can't import says file not found. The path is fuelio6.db and version is 3.80. http://dmwebsolution.com/  Thank you for sharing this information.