+6
Under review

Can't sync with Google Drive

José Pablo Longhi fa 6 anys • updated by Nuri Uzunçakmak fa 4 anys 9

I bought pro version in order to backup data in Google Drive. I already provide my google account and received a warning notification on my phone saying “Permission requested” for x@gmail.com. But nothing happens; I can’t see Fuelio db on my Google Drive folder. Then when I try with "Send to Google Drive" button the application said "Internet Connection Error. Check your network setting or try again" I’m completely sure my phone has Internet

I'm using new Google Drive API which is still beta. I know there can be sometimes such errors.

Try to go back to Dashboard, and then again goto Google Drive. 


If you linked you account - that's great. And one more thing. If you have seen "Permission requested ...". Did you tap on it. Google should show you permission to Google Drive and you should accept it.


You should also see Fuelio in your Google Account apps permission. 


Make sure you have a good internet connection and tap "Send to Google Drive" few more times.


In the next realease I'll update Google Play Services library (because there is new version from Google). 

Yes, I think thats the issue, when I tap on "Permission Request.."  doesnt prompt anything to accept.


I already  backup with dropbox for now.


Thanks.

I don't know how to handle this. This is Google's request and it shows you notification from Google servers (only once). 


Try to change your Google account - reauth.


Dropbox API is much better in my opinion.

OK, but I will stay with dropbox, works better, besides I already have other apps sync with it. 


Thank you

I had the same problem. Pro 3.4.1, Nexus S, CM 11. I've removed my Google account then added it again. It asked for the permission once and I accepted. This didn't solve the problem.

Then, on my Drive, I've deleted the "Android" folder. Back on Fuelio, I've been able to sync it successfully.
I forgot to say I already had synced Fuelio before, not sure when, maybe in January. I've changed Android and Fuelio versions since then.
Same as here. I cant sync with google drive. Then when I try with "Send to Google Drive" button the application said "Internet Connection Error. Check your network setting or try again" I’m completely sure my phone has Internet
+2
Under review
Go to your Google Drive account. Check if you have Android directory there. Rename it for a moment. And then try to do backup.

This is probably permission problem to this directory.
+1
Thanks for the answer. I've checked it's not does exist.

UPDATE: Sorry, I'm sorry if I've been wrong had. the problem was solved thanks.