0
Under review

Trip does not end after disconnecting from car (auto-launch feature)

Matus 2 years ago updated by Adrian 2 years ago 11

I started using auto-launch and for most trips it works perfectly OK - trip starts when phone Bluetooth connects to car and it ends when Bluetooth is disconnected. However, despite "start" works reliably, the "end" does not - on some occasions the trip continues to be "in progress" and it only finishes with the end of the next trip. There is even no way to finish the trip manually (it does not show in notification center).

Under review

We trying to detect this but some devices (in cars) are not returning intent and Fuelio don't know when to disconnect.

Of course you can always finish or pause your trip.


Notification - swipe down on notification - there are 2 buttons there - FINISH and PAUSE.

You can finish trip recording anytime you want using these buttons.

Thanks for response and clarification. I know it is in beta, so hopefully this improves as it saves A LOT of manual effort and was a reason why I stopped using Fuelio before.


Anyway, as I mentioned above, unfortunately, I don't have anything from Fuelio in notification center. I only see that trip is in progress when I open the actual app - I can see there trip start date/time, that it is 0.0 km and that it is in progress. The distance and end time appear only after next trip (if it auto-ends successfully).

Start trip recording. Open notifications - swipe down from the top (I don't know what's notification center). 
You should see info TRIP RECORDING. Swipe down on this and there are 2 buttons. There's no way they are not there, only on newer android version if you have more notifications Android is hiding this and you need to swipe down.

You can mail me screenshots from your device (mail from Play Store)

If there is no notification it's not possible that any service is running. The trip in progress means some old trip not saved in most cases it's empty trip. If you remember, give me some details how you are recording this using autostart. I'm using it all the time (more than 1000 trips). I get sometimes problem with disconnect (underground parkings) - I'm working on this but for most trips it is working really stable. 

Try also to change timeout in settings for Trip Log (Settings -> Trip Log)

Thanks for swift reply, Adrian.

If I start trip manually, the notification is there and I can stop the trip. (that's what I called notification center - we mean the same thing: https://www.facebook.com/Fuelio/videos/616080862139880/ ). 

However the notification is not there if trip was auto-started and did not properly end after disconnecting from car bluetooth. In such circumstances I don't see it in notifications - only in the app it shows as "In progress". (and it is not "hidden")

HI Adrian. Thanks for your help. 

I have succeeded to "finish" that "in progress" trip by editing it's data - I have opened that trip in app, manually set end date, end location, beginning mileage and end mileage and the trip (which was showing as "in progress" and had no notification to finish it) shows data now (except that GPS track is missing). Therefore I don't have screenshot of that anymore but will post if it re-occurs.

What may be of interest when you mentioned it - I ended that "unfinished" trip in underground garage, so it may be a culprit there. Today morning I finished again underground and before shutting the engine (and car unit) I ended the trip manually through the notification and it worked (including GPS track). I'll keep testing and will post here any observations.

Hi Adrian,

Unfortunately, it seems that the issue with trips stucking "In progress" is getting worse and worse as most of the trips lately are unfinished (even if there's full signal and 4G coverage). Sending screenshots and let me know if you'd like any further details.

Thank you.

OK. But did you finish the trips from notification?
What phone do you have. Maybe it's some setting for your phone.

I have no idea how to reproduce this. I did >10k km with Trip Log. 

It's hard to say based on your screenshots. 

Could you one again write down - how to you start working with Trip Log.
You know - you are going to your car, you are doing this and this. YOu see notification, you see other stuff.

Check GPS settings for sure (if it's using GPS provider - not WIFI).

First of all. When Trip Log starts, you should see notification, while dirving - km in notification should change.

The only possibility to have "in progress" means the trip recording is in the backgroun - so this is something interesting.

I am using the Autostart feature (screenshot below) - whenever I start the car, the phone connects to it's Bluetooth unit and trip starts automatically. The expectation is, when I turn off the engine, the Bluetooth disconnects (in app I have default 20 seconds disconnect timeout, but tried with 10s too, with no improvement) and trip ends automatically too and is logged in the trip log (with distance, GPS-log of the route, start time, end time, etc.). However that is not happening all the time (sometimes yes, sometimes no ... lately rather no as you can see from screenshot above).

If I try to finish the trip manually (from notification) before I stop the car engine and before the Bluetooth disconnects, the trip logs fine with all the details (distance, GPS route, start/end time - and it works even if there's no GPS signal). However once I stop the engine and Bluetooth disconnects, the notification disappears and the trip sometimes (most of the times now) remains "In progress" (as on the other screenshot above - there are no data for the trip, only start time is captured).

So what I do when it (sometimes) does not work:

  1. start the engine (trip auto-starts)
  2. drive (trip data is being captured)
  3. stop the engine (trip should auto-end, but it sometimes does not and notification to finish trip is not there anymore)

It only works reliably when I:

  1. start the engine (trip auto-starts)
  2. drive (trip data is being captured)
  3. take phone and finish the trip through notification manually
  4. stop the engine

My phone is Nokia 8 and adding few other screenshots from trip-log settings - hope it helps. Thank you.

Could you mail me? Mail from Play Store. I'd like to give you (generate APK with some debug options). I'm really interested at which point it's not working for you (it is phone, some limitation from Nokia, not sure here).