Twoje komentarze

Settings -> Export -> And me file from /sdcard/Fuelio/backup-db/fuelio6.db.


How did you install 3.1 version? Database schema changes. Maybe you have imported old file. But you should probably know about it.


Could you send me your .db file?

Try to put it on Dropbox or Google Drive and share a link.

To raczej nie jest problem Fuelio, a urządzenia i systemu przygotowanego pod niego. 

Ja aktualizuję aplikację, ale to Google dopasowuje urządzenia do aplikacji. Wydaje mi się, że po prostu Modecom Freeway w żaden sposób nie aktualizuje swoich urządzeń czyt. na urządzeniu nie zaktualizowało się coś takiego jak Google Play Services. W tej chwili to silnik dla wielu aplikacji. Google na urządzeniach 2.2+ aktualizuje ten pakiej automatycznie (w tle). Na to nie mam wpływu.


Google od pewnego czasu prawdę mówiąc stara się "zabijać" androida z serii 2.x. Nawet zalecenia deweloperów są już takie żeby ustawiać minimalną wersją dla 4.x. 


Fuelio używa teraz nowego API map, które są częścią jak wspomniałem Google Play Services. To był krok konieczny, nie da się juz generować kluczy deweloperskich do API starych map. Więcj należy korzystać z nowego. 


Na tym urządzeniu nie zadziała teraz wiele innych aplikacji z tego powodu. 

Można sprawdzić czy da się zainstalować ten pakiet: https://play.google.com/store/apps/details?id=com.google.android.gms&hl=pl


na urządzeniu. Jeśli będą problemy - to jest problem z systemem i raczej cięzko będzie zainstalować jakąkolwiek aplikację korzystająca z Google Play Services (a to naprawde jest prawie wszystko - mapy, drive, zarządzanie kontami...).


Raczej nie da się nic zrobić jeśli na urządzeniu nie da się mieć aktualnych usług Google'a i wyjściem faktycznie jest notes lub znalezienie jakiejś starej aplikacji (nie korzystającej z nowych API).


Poszukałbym aktualizacji dla tego sprzętu. Może jakaś jest? Czy producent nie wydaje żadnych poprawek systemu? Warto to sprawdzić. Bo to nie jest problem Fuelio tylko faktycznie już przestarzałego systemu. 


Pierwsze wersje faktycznie były wydane jeszcze za czasów starego Androida i wszystko działało. Ale sprawdziłbym czy nie da się zainstalować tych usług lub czy producent nie wydał nowszego systemu.


Na 2.3 na przykład, bo mam jeden stary telefon gdzie nowe usługi Google Play działają wszystko działa pięknie. 

Numeric keypad is active in my app. What keyboard are you using? 

Try for example Stock Android,  SwiftKey or Swype. You should see numeric keyboard by default. 

You had old database schema. This could be connected to a very old bug from the 1.x version. Or you have imported old backup to newer version of Fuelio.


I think I fixed it. It will be changed with 3.0.2 verion.

That would be great.

There are some roundings. But like I said this shouldn't be higher that 0.02. In many countries these some values have 3 decimals. 


Maybe I should create special position in settings. It's a little bit problamatic.


Your CSV could be useful for some tests.