Import CSV Format

Michael Ingraham 8 years ago updated by Adrian 4 years ago 25

I am just starting to use the app on Android.  I have fill-up information for our cars in an Excel spreadsheet.  I want to put that data into the right format to import into the app.  I tried adding a vehicle and adding one fill-up and exporting from Fuelio.  I searched my storage using Solid Explorer but I cannot find the exported file.  In any case, what I really need is the field order for the CSV import file so I can create the file to import into Fuelio.  Thanks.



Dropbox is much better here. With Drive it's because of permission. Fuelio can have access only to files you have created with the app. You. You need to download file to your from Drive app and use standard import option (you can browse for files while importing.

This is basic Fuelio sample: https://dl.dropbox.com/u/6838779/fuelio-sample.zip

You need to put .csv file at path /SDCARD/Fuelio/fuelio-csv/

If you have phone with SDCARD - directory named Fuelio should be there. If you have phone without SDCARD, you have SDCARD directory and at the same path you'll find Fuelio files.

If you have PRO version - you can use directories in your Dropbox/Apps/Fuelio/backup-csv/ directory.

I've tried multiple times with slight variations (dashes instead of slashes in dates, no optional fields, etc.). Either every row is an error or the app crashes. I'd be happy to send you the CSV file.  Perhaps you could inspect it to let me know where my problem is. Thanks.

Hi, I'm interested to follow this thread.  I am importing my data with csv file and am experiencing same error and/or crash.  I followed the same steps and exported a csv using 2 'fake' fill-ups created within Fuelio, then opened the csv in Excel and pasted my data over top.  However it still causes a crash and I can't identify why.  Are there limits on number of decimals, cell format, etc.?  

Great looking app and I look forward to using it.

Send me your file. I'll fix it for you. 

The sample that I received from Adrian had every field in double quotes separated commas.  Also, the date was in yyyy-mm-dd format (also enclosed in quotes.  The quotes and the date format were the only two things I saw that I had not attempted.

I just tried to create a file for another vehicle.  It seems that you have to also have a blank field in each record even for the optional fields (MPG,GPS coordinates, City) or the import will fail.

This is your file: https://dl.dropbox.com/u/6838779/rick2-done.csv

But take a look at your data. There is probably something wrong. You've got probably one of your fill-up marked as full. Or you've got really bad fuel consumption on one. But mostly if I see such a numbers there is something wrong. I changed this fill-up to be partial and fuel consumption looks normal. 

Hi Adek,

Read some good reviews about your app, puchased, but need some info in regards to the following:

1) I've purchased and installed your Fuelio app, and i see two icons, Fuelio Pro Key and then the app itself Fuelio, where can i check i have got the full version, because the Pro Key icon when pressed says "Application is not installed" should my icon say Fuelio Pro? with the red banner 

2) I am transistioning from Vehical (iPhone 4 app) to Fuelio, and i've gone through this thread and adjusted my Vehical CSV file to suit your template but its still saying it has errors, can i send you my file for you to look at? how do i send it to you

Many Thanks


1) To use Pro functions you need PRO key installed in your system. That's it. Nothing else. Don't uninstall Fuelio app (the free one). If you have Fuelio and Fuelio PRO in your system you can run fuelio (main app, not the key) and you'll see additional features. 

2) Yes. Send me your file

Whats your email address? so i can send you the file

Also is there any way to check i am running the Pro version? i did purchase the key. E.g. Will Dropbox backup work if its the free version?

Adek, how can i send you the file, please advise.


Yes, of course. Like I said before. My mail is on fuelio.mobi page.

Hi, can you please contact me so i can send you my file, i've bought this app and i cannot use it until ive imported my old data across.



I don't know your mail but you should know my :) Please, send me your CSV.

You'll find my mail at fuelio.mobi page or Google Play Store page: adrian.kajda+fuelio(at)gmail.com.

If you have PRO version you should be able to swipe right and see Cost module.

I am located in the US so I have my info using the Imperial system (mpg, etc...) When I try to import this information, the same thing as above happens. How can I fix this problem?

You have CSV from other app and you are trying to import data?

I have an Excel CSV file but it doesn't show in Fuelio when I import it.

You need to prepare excel file to be in Fuelio format. As you know Excel is open format. The data could look different.

You need to put columns in the right order etc.

Basic file for fillups is here: http://fuel.io/faq/ (this is minimal CSV file)

I've tried doing what you recommended and it's still not importing. I even tried downloading from my Dropbox account and THAT isn't working. I have 56 different lines of information and I'm NOT going to enter them separately! I guess I just need to use a different software. :-(

Mail me your file: fuelio@sygic.com

The App is very good, so i want to change from a App who let not make no backup.

My problem here is, that import function only show the files i have exportet to G-Drive.
I can rename it on G-Drive and the Renamed files are shown on the Phone! But not the new created (Notepad++).


Dropbox is much better here. With Drive it's because of permission. Fuelio can have access only to files you have created with the app. You. You need to download file to your from Drive app and use standard import option (you can browse for files while importing.

I think i have fixed the fault

I used the File from FAQ, but let the first Line of the original EXPORT

The new Header looks so:

"## Vehicle"

in the FAQ it looks so

## Vehicle

So, the first Line must have the " " , but no where else i have " "!!!!

And I have to edit a EXPORTFILE, if I copy a file that work, I can't see it on the phone. (Like you say: Drive permission)
Try Dropbox sometime.

In FAQ there is minimal file. Full CSV looks a little bit different. But I'm happy it works :)